System.Data.SQLite
Artifact Content
Not logged in

Artifact e35d4c2b8fc81f82eccb07c5a85d45cdb82c607a:


<title>Downloads Page</title>
<nowiki>
  <h1 class="pageHeader">System.Data.SQLite Downloads</h1>

  <table width="100%" cellpadding="5" cellspacing="0">
    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantHeader">
        <a name="runtimeLibraryNotes"></a>
        <b>Runtime Library Notes</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantNotes">
        All downloadable packages on this web page that do not include
        the word &quot;<b>static</b>&quot; in their file name require the
        appropriate version (e.g. 2005, 2008, 2010, 2012, 2013, 2015, 2017) of
        the Microsoft Visual C++ Runtime Library, to be successfully installed
        on the target machine, prior to making use of the executables contained
        therein.  It should also be noted that the downloadable packages on this
        web page that include the word &quot;<b>setup</b>&quot; (i.e. the setup
        packages) already include and will attempt to automatically install the
        required version of the Microsoft Visual C++ Runtime Library.
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantHeader">
        <a name="msvcDownloads"></a>
        <b>Latest Microsoft Visual C++ Runtime Library Downloads</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantNotes">
        For detailed information about the latest downloads for each Microsoft
        Visual C++ Runtime Library release, please refer to the following page:
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td class="importantNotes">
        &nbsp;
      </td>
      <td class="importantNotes" align="center">
        <a href="https://support.microsoft.com/kb/2019667">Latest Supported
        Visual C++ Downloads</a>
      </td>
      <td class="importantNotes">
        &nbsp;
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantHeader">
        <a name="supportNotesDownloadablePackages"></a>
        <b>Support Notes - Downloadable Packages</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantNotes">
        This page contains all the downloadable packages (e.g. sources,
        binaries, setups, etc) for the current release version of the official
        &quot;System.Data.SQLite&quot; project.  This page and the associated
        <a href="https://www.nuget.org/profiles/SQLite">NuGet packages</a>
        are the <b>only</b> official distribution points for these downloadable
        packages.  If any of the downloadable packages are obtained elsewhere,
        it is very important to compare their SHA1 hashes to the corresponding
        hashes listed below in order to make sure the contained files are the
        same.
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantHeader">
        <a name="supportNotesOtherProjects"></a>
        <b>Support Notes - Other Projects</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantNotes">
        There are several other projects, with widely varying levels of support
        and compatibility, known to use the similar names.  At least one of
        those projects is an unofficial fork of the legacy 1.0.66.0 release,
        modified (by a third-party) to work with Visual Studio 2010 (or higher).
        Only the software contained on this page is directly
        <a href="support.wiki">supported</a> by the maintainers of this project
        (i.e. the <a href="https://www.sqlite.org">SQLite Development Team</a>)
        as we do not necessarily have any knowledge of the other projects that
        use the same (or a similar) name.  That being said, if a particular
        question is related to the core SQLite native library itself, one of the
        <a href="https://www.sqlite.org/support.html">SQLite support options</a>
        is probably the best way to get an answer.
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantHeader">
        <a name="windowsEmbeddedCompact"></a>
        <b>Windows Embedded Compact</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="3" class="importantNotes">
        The <a href="#sqlite-netFx35-binary-PocketPC-ARM-2008">Precompiled
        Binaries for Windows CE (.NET Compact Framework)</a> section of this
        page contains several binary packages for Windows Embedded Compact
        2013.  Further information on integrating SQLite into Windows Embedded
        Compact 2013 can be found at the following web site:
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td class="importantNotes">
        &nbsp;
      </td>
      <td class="importantNotes" align="center">
        <a href="https://cesqlite2013.codeplex.com/">SQLite for Windows
        Embedded Compact 2013</a>
      </td>
      <td class="importantNotes">
        &nbsp;
      </td>
    </tr>
  </table>

  <table width="100%" cellpadding="5">
    <tr>
      <td colspan="3" class="importantHeader">
        <a name="releaseNotes"></a>
        <b>Release Notes</b>
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantNotes">
        The &quot;release notes&quot;, which contain lists of notable changes
        associated with each officially released version, is available on the
        <a href="news.wiki">News</a> page.
      </td>
    </tr>
  </table>

  <table width="100%" cellpadding="5">
    <tr>
      <td colspan="3" class="importantHeader">
        <a name="packageTypes"></a>
        <b>Package Types</b>
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantNotes">
        There are a wide variety of downloadable packages on this page.
        Each of them is designed to meet the requirements of a particular
        development and/or deployment scenario.
        <br /><br />
        The first step is to determine if the package is to be installed (or
        used) on a developer machine or a customer machine.
      </td>
    </tr>
    <tr>
      <td>
        &nbsp;
      </td>
      <td class="importantNotes">
        <ul>
          <li>
            The source packages are intended primarily for people interested in
            studying the source code that corresponds to a particular release
            version of the project.  The source packages contain no binaries.
            Those interested in studying the latest source code and/or tracking
            the unreleased changes should consider accessing the
            <a href="/index.html/timeline?n=20&y=ci">Fossil repository</a>
            instead.
          </li>
          <br />
          <li>
            The setup packages are intended to be installed <b>only</b> on
            developer machines and then <b>only</b> when the design-time
            components for Visual Studio are required.  In theory, they can be
            installed on customer machines as well; however, this type of
            deployment is not recommended.
          </li>
          <br />
          <li>
            The binary packages are intended to be used by developers in order
            to obtain the assembly binaries necessary for development and
            deployment of their applications onto customer machines via
            <a href="https://en.wikipedia.org/wiki/XCOPY_deployment">XCOPY
            deployment</a>.
          </li>
        </ul>
      </td>
      <td>
        &nbsp;
      </td>
    </tr>
    <tr>
      <td colspan="3" class="importantNotes">
        All the &quot;bundle&quot; packages contain the
        &quot;System.Data.SQLite.dll&quot; mixed-mode assembly.  These packages
        should <b>only</b> be used in cases where the assembly binary
        <b>must</b> be deployed to the
        <a href="https://en.wikipedia.org/wiki/Global_Assembly_Cache">Global
        Assembly Cache</a> for some reason (e.g. to support some legacy
        application on customer machines).
        <br /><br />
        All the &quot;static&quot; packages contain either native or mixed-mode
        assembly binaries linked statically to the appropriate version of the
        <a href="https://en.wikipedia.org/wiki/Visual_C++">Visual C++</a>
        runtime.  Typically, these packages are used in cases where customer
        machines may not have the necessary version of the Visual C++ runtime
        installed and it cannot be installed due to limited privileges.
        <br /><br />
        The next step is to identify the version of the
        <a href="https://en.wikipedia.org/wiki/.NET_Framework">.NET Framework</a>
        being targeted by the application.
        Generally, assembly binaries linked against the
        <a href="http://go.microsoft.com/fwlink/?LinkID=32168">.NET Framework
        2.0</a> (or the
        <a href="http://go.microsoft.com/fwlink/?LinkId=124150">.NET Framework
        3.5</a>) will work with the
        <a href="http://go.microsoft.com/fwlink/?LinkID=186913">.NET Framework
        4.0</a> (or higher); however, this is less than ideal.  Furthermore,
        assemblies linked against the .NET Framework 4.0 (or higher)
        <b>cannot</b> be loaded by any versions of the .NET Framework prior to
        4.0.
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantHeader">
        <a name="nativeLibraryPreLoading"></a>
        <b>Using Native Library Pre-Loading</b>
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantNotes">
        The final step is to identify the target processor architecture on both
        the development and customer machines.  Generally,
        <a href="https://en.wikipedia.org/wiki/X86">x86</a> binaries will work on
        an <a href="https://en.wikipedia.org/wiki/X64">x64</a> machine running
        <a href="https://en.wikipedia.org/wiki/Windows">Windows</a> (using
        <a href="https://en.wikipedia.org/wiki/WoW64">WoW64</a>).  However, there
        is a problem when using managed code.  If the executable that starts the
        process consists entirely of managed code, it will run with the native
        processor architecture of the machine, which will be x64 on an x64
        machine.  Later on, this will cause assemblies containing any native
        code compiled for x86 (e.g. the &quot;System.Data.SQLite.dll&quot;
        mixed-mode assembly, the &quot;SQLite.Interop.dll&quot; native interop
        assembly, or the &quot;sqlite3.dll&quot; native library) to fail to
        load, typically resulting in a
        <a href="faq.wiki#q12">BadImageFormatException</a> being thrown.
        <br /><br />
        If the development and customer machines may have different processor
        architectures, more than one binary package may be required.  For this
        situation, using the <b>native library pre-loading feature</b> is highly
        recommended.  It is available as of version 1.0.80.0 and enabled by
        default.  In order to take advantage of this feature, the separate
        managed and interop assemblies <b>must</b> be used with XCOPY deployment
        (i.e. this feature is not supported by the mixed-mode assembly, nor when
        the assembly is deployed to the global assembly cache), resulting in an
        application deployment that looks something like this:
      </td>
    </tr>
    <tr>
      <td>
        &nbsp;
      </td>
      <td width="90%" class="importantNotes">
        <ul>
          <li>
            <b>&lt;bin&gt;\App.exe</b> (optional, managed-only application
            executable assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\App.dll</b> (optional, managed-only application
            library assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\System.Data.SQLite.dll</b> (required, managed-only
            core assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\System.Data.SQLite.Linq.dll</b> (optional,
            managed-only LINQ assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\System.Data.SQLite.EF6.dll</b> (optional,
            managed-only EF6 assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\x86\SQLite.Interop.dll</b> (required, x86 native
            interop assembly)
          </li>
          <li>
            <b>&lt;bin&gt;\x64\SQLite.Interop.dll</b> (required, x64 native
            interop assembly)
          </li>
        </ul>
      </td>
      <td>
        &nbsp;
      </td>
    </tr>
    <tr>
      <td colspan="3" class="importantNotes">
        The string &quot;<b>&lt;bin&gt;</b>&quot; above represents the directory
        where the application binaries are to be deployed on the target machine.
        With the native library pre-loading feature enabled and the application
        deployment shown above, the System.Data.SQLite managed-only assembly
        will attempt to automatically detect the processor architecture of the
        current process and pre-load the appropriate native library.
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantHeader">
        <a name="advancedConfigurationSettings"></a>
        <b>Advanced Configuration Settings</b>
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantNotes">
        If native library pre-loading feature does not work properly in your
        environment, it can be disabled by setting the
        &quot;No_PreLoadSQLite&quot; environment variable (i.e. to anything)
        prior to loading and/or using the System.Data.SQLite assembly.  There
        are several more environment variables that can be used to influence the
        behavior of the native library pre-loading feature, documented
        <a href="/index.html/artifact?ci=trunk&filename=Doc/Extra/Provider/environment.html">here</a>.
        <br /><br />
        Use of environment variables for configuration settings is not
        supported by the .NET Compact Framework builds of System.Data.SQLite,
        due to limitations imposed by the platform itself.
        <br /><br />
        Alternatively, as of version 1.0.91.0, all configuration settings can be
        specified via an optional
        <a href="/index.html/artifact?ci=trunk&filename=System.Data.SQLite/Configurations/System.Data.SQLite.dll.config">XML configuration file</a>.
        Using the XML configuration file when the primary System.Data.SQLite
        assembly (&quot;System.Data.SQLite.dll&quot;) is being executed from the
        Global Assembly Cache is <b>unsupported</b>.
        <br /><br />
        For each configuration setting, the associated environment variable
        value, if present, will override the value specified via the XML
        configuration file.
        <br /><br />
        For the full .NET Framework, the XML configuration file <b>must</b> be
        named &quot;<b>System.Data.SQLite.dll.config</b>&quot; and it
        <b>must</b> be present in the
        <a href="https://msdn.microsoft.com/en-us/library/system.appdomain.basedirectory%28v=vs.80%29.aspx">base directory for the application domain</a>
        <b>or</b> the directory containing the primary System.Data.SQLite
        assembly as reported by its
        <a href="https://msdn.microsoft.com/en-us/library/system.reflection.assembly.location%28v=vs.80%29.aspx">location</a>
        property; otherwise, it will be ignored.
        <br /><br />
        For the .NET Compact Framework, the XML configuration file <b>must</b>
        be named &quot;<b>System.Data.SQLite.dll.config</b>&quot; and it
        <b>must</b> be present in the directory containing the primary
        System.Data.SQLite assembly; otherwise, it will be ignored.
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantHeader">
        <a name="deploymentGuidelines"></a>
        <b>Deployment Guidelines</b>
      </td>
    </tr>

    <tr>
      <td colspan="3" class="importantNotes">
        To summarize the above:
      </td>
    </tr>
    <tr>
      <td>
        &nbsp;
      </td>
      <td width="90%" class="importantNotes">
        <ul>
          <li>
            Using XCOPY deployment in conjunction with the native library
            pre-loading feature, especially for customer machines, is highly
            recommended.
          </li>
          <br />
          <li>
            Using the Global Assembly Cache (at all) is not recommended;
            therefore, the &quot;bundle&quot; packages should be avoided unless
            deemed absolutely necessary.
          </li>
          <br />
          <li>
            Using the &quot;static&quot; assembly binaries on development
            machines is not recommended; therefore, the &quot;static&quot;
            packages should be avoided if all the target machines already have
            the Visual C++ runtime installed or it can be easily deployed
            beforehand.
          </li>
          <br />
          <li>
            Choosing the package matching the version of the .NET Framework
            being targeted is highly recommended.
          </li>
          <br />
          <li>
            Choosing the package matching the target processor architecture (for
            both development and customer machines) is almost certainly required
            for proper operation.  Using the native library pre-loading feature
            should help with this.
          </li>
        </ul>
      </td>
      <td>
        &nbsp;
      </td>
    </tr>
  </table>

  <table width="100%" cellpadding="5">
    <tr>
      <td align="center">
        <h2 class="pageSubHeader">List of Release Packages</h2>
      </td>
    </tr>
  </table>

  <table width="100%" cellpadding="5">
    <tr>
      <td colspan="4">
        <b>Source Code</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx-source"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx-source-1.0.110.0.zip">sqlite-netFx-source-1.0.110.0.zip</a>
        <br />
        (6.53 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This ZIP archive contains all current source code for System.Data.SQLite
        1.0.110.0 (3.27.2) combined into a single archive file.
        <br />
        (sha1: 6d897ffd0f5a8a49afbe6b77a85eeefdc4262850)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx-full-source"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx-full-source-1.0.110.0.zip">sqlite-netFx-full-source-1.0.110.0.zip</a>
        <br />
        (11.39 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This ZIP archive contains all current source code for System.Data.SQLite
        1.0.110.0 (3.27.2) and the extra files needed to run the unit test suite,
        combined into a single archive file.
        <br />
        (sha1: 3ad571c64cedae7169c593fbb3c5caf7353636d6)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-setup-bundle-x86-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-setup-bundle-x86-2005-1.0.110.0.exe">sqlite-netFx20-setup-bundle-x86-2005-1.0.110.0.exe</a>
        <br />
        (5.63 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005
        SP1 runtime for x86 is included.  The .NET Framework 2.0 SP2 is
        required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2005.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        (sha1: 2c233d95e3e89ad4bde6990b9f54a9eff31b13de)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-setup-x86-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-setup-x86-2005-1.0.110.0.exe">sqlite-netFx20-setup-x86-2005-1.0.110.0.exe</a>
        <br />
        (5.61 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x86 is included.
        The .NET Framework 2.0 SP2 is required.
        <br />
        (sha1: e30ad098774a1108afa375df87928e2c155aac63)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-setup-bundle-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-setup-bundle-x64-2005-1.0.110.0.exe">sqlite-netFx20-setup-bundle-x64-2005-1.0.110.0.exe</a>
        <br />
        (6.28 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005
        SP1 runtime for x64 is included.  The .NET Framework 2.0 SP2 is
        required.
        <br />
        (sha1: dabf70dcf5b749010a6ac3ff4fe1c0914ffbd21a)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-setup-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-setup-x64-2005-1.0.110.0.exe">sqlite-netFx20-setup-x64-2005-1.0.110.0.exe</a>
        <br />
        (6.27 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x64 is included.
        The .NET Framework 2.0 SP2 is required.
        <br />
        (sha1: 9828190eb3275a229141fe36694dece722494afd)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-setup-bundle-x86-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-setup-bundle-x86-2008-1.0.110.0.exe">sqlite-netFx35-setup-bundle-x86-2008-1.0.110.0.exe</a>
        <br />
        (7.66 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008
        SP1 runtime for x86 is included.  The .NET Framework 3.5 SP1 is
        required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2008.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        (sha1: 8cb3c9cfd7ed9b768ff1a986c5a73a420c4da863)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-setup-x86-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-setup-x86-2008-1.0.110.0.exe">sqlite-netFx35-setup-x86-2008-1.0.110.0.exe</a>
        <br />
        (7.65 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x86 is included.
        The .NET Framework 3.5 SP1 is required.
        <br />
        (sha1: ff8d394ee89314345e3e3219453482a0d5155d68)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-setup-bundle-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-setup-bundle-x64-2008-1.0.110.0.exe">sqlite-netFx35-setup-bundle-x64-2008-1.0.110.0.exe</a>
        <br />
        (8.43 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008
        SP1 runtime for x64 is included.  The .NET Framework 3.5 SP1 is
        required.
        <br />
        (sha1: 94714e8be6f348c410cac9aa2cc8ddc7d2ac02ff)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-setup-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-setup-x64-2008-1.0.110.0.exe">sqlite-netFx35-setup-x64-2008-1.0.110.0.exe</a>
        <br />
        (8.42 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x64 is included.
        The .NET Framework 3.5 SP1 is required.
        <br />
        (sha1: 1b74ee4b0beb856aae884a0bbf9170e9a2cb5b1b)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-setup-bundle-x86-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-setup-bundle-x86-2010-1.0.110.0.exe">sqlite-netFx40-setup-bundle-x86-2010-1.0.110.0.exe</a>
        <br />
        (13.25 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010
        SP1 runtime for x86 is included.  The .NET Framework 4.0 is required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2010.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        (sha1: 51ee805bf174a0db8a9ae6202360c034fc631c72)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-setup-x86-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-setup-x86-2010-1.0.110.0.exe">sqlite-netFx40-setup-x86-2010-1.0.110.0.exe</a>
        <br />
        (13.23 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x86 is included.
        The .NET Framework 4.0 is required.
        <br />
        (sha1: 254f0871e5ea2917ad5fc8804d8a2cec1bf0caef)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-setup-bundle-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-setup-bundle-x64-2010-1.0.110.0.exe">sqlite-netFx40-setup-bundle-x64-2010-1.0.110.0.exe</a>
        <br />
        (14.52 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010
        SP1 runtime for x64 is included.  The .NET Framework 4.0 is required.
        <br />
        (sha1: 5a0336da20316ee9247eab56c226c1e8049ec5ba)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-setup-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-setup-x64-2010-1.0.110.0.exe">sqlite-netFx40-setup-x64-2010-1.0.110.0.exe</a>
        <br />
        (14.51 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x64 is included.
        The .NET Framework 4.0 is required.
        <br />
        (sha1: 18aa93c6d37bbef046baa46e2b4df70cebe063cd)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-setup-bundle-x86-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-setup-bundle-x86-2012-1.0.110.0.exe">sqlite-netFx45-setup-bundle-x86-2012-1.0.110.0.exe</a>
        <br />
        (10.66 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x86 is included.  The .NET Framework 4.5 is
        required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2012.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        <big><b>Using Entity Framework 6 design-time support may require
        installing the Visual Studio 2012 &quot;flavor&quot; of the
        <a href="https://www.microsoft.com/en-us/download/details.aspx?id=40762">
        Entity Framework 6 Tools for Visual Studio 2012 &amp; 2013</a>.</b></big>
        <br />
        <br />
        (sha1: 29bdb2943862b9fc2fb73d3b0fa1f8d03d43d851)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-setup-x86-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-setup-x86-2012-1.0.110.0.exe">sqlite-netFx45-setup-x86-2012-1.0.110.0.exe</a>
        <br />
        (10.70 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x86 is
        included.  The .NET Framework 4.5 is required.
        <br />
        (sha1: 9f920ac520f78becdaa6785e88acb596538ace0a)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-setup-bundle-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-setup-bundle-x64-2012-1.0.110.0.exe">sqlite-netFx45-setup-bundle-x64-2012-1.0.110.0.exe</a>
        <br />
        (11.33 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x64 is included.  The .NET Framework 4.5 is
        required.
        <br />
        (sha1: 2f66971944947afc9d9cf51ca521166b69de1e5d)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-setup-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-setup-x64-2012-1.0.110.0.exe">sqlite-netFx45-setup-x64-2012-1.0.110.0.exe</a>
        <br />
        (11.40 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x64 is
        included.  The .NET Framework 4.5 is required.
        <br />
        (sha1: 160588d7072c140d214e5be8f61f188738574642)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-setup-bundle-x86-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-setup-bundle-x86-2013-1.0.110.0.exe">sqlite-netFx451-setup-bundle-x86-2013-1.0.110.0.exe</a>
        <br />
        (10.62 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x86 is included.  The .NET Framework 4.5.1 is
        required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2013.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        <big><b>Using Entity Framework 6 design-time support may require
        installing the Visual Studio 2013 &quot;flavor&quot; of the
        <a href="https://www.microsoft.com/en-us/download/details.aspx?id=40762">
        Entity Framework 6 Tools for Visual Studio 2012 &amp; 2013</a>.</b></big>
        <br />
        <br />
        (sha1: c330a68b45f4958a96674aed1c2ef2791ed94cbe)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-setup-x86-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-setup-x86-2013-1.0.110.0.exe">sqlite-netFx451-setup-x86-2013-1.0.110.0.exe</a>
        <br />
        (10.65 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x86 is
        included.  The .NET Framework 4.5.1 is required.
        <br />
        (sha1: 694b349b4b1c75521884d09efd6627c7f40604f6)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-setup-bundle-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-setup-bundle-x64-2013-1.0.110.0.exe">sqlite-netFx451-setup-bundle-x64-2013-1.0.110.0.exe</a>
        <br />
        (11.32 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x64 is included.  The .NET Framework 4.5.1 is
        required.
        <br />
        (sha1: 9a0cc51915dddb23f2d491e8e6c0b09885045945)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-setup-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-setup-x64-2013-1.0.110.0.exe">sqlite-netFx451-setup-x64-2013-1.0.110.0.exe</a>
        <br />
        (11.39 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x64 is
        included.  The .NET Framework 4.5.1 is required.
        <br />
        (sha1: 48fe71a5d05e820eec7e8634de4d5aad082b591e)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 32-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-setup-bundle-x86-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-setup-bundle-x86-2015-1.0.110.0.exe">sqlite-netFx46-setup-bundle-x86-2015-1.0.110.0.exe</a>
        <br />
        (17.21 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x86 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x86 is included.  The .NET Framework 4.6 is
        required.
        <br />
        <big><b>This is the only setup package that is capable of installing the
        design-time components for Visual Studio 2015.
        <br />
        <br />
        However, if you do not require the design-time components, please
        consider downloading the associated &quot;Precompiled Binaries&quot;
        instead.</b></big>
        <br />
        <br />
        (sha1: 5188f4d1aafe73e5b07851fec84db286c152ed82)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-setup-x86-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-setup-x86-2015-1.0.110.0.exe">sqlite-netFx46-setup-x86-2015-1.0.110.0.exe</a>
        <br />
        (17.37 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x86 is
        included.  The .NET Framework 4.6 is required.
        <br />
        (sha1: 9f0911d375bc707b1dbfb486e1e0c47703ea2ff0)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Setups for 64-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-setup-bundle-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-setup-bundle-x64-2015-1.0.110.0.exe">sqlite-netFx46-setup-bundle-x64-2015-1.0.110.0.exe</a>
        <br />
        (18.06 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package features the mixed-mode assembly and will install all
        the necessary runtime components and dependencies for the x64 version of
        the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x64 is included.  The .NET Framework 4.6 is
        required.
        <br />
        (sha1: 3937ac803ed9e6205c0780f3fac131ee70f09b57)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-setup-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-setup-x64-2015-1.0.110.0.exe">sqlite-netFx46-setup-x64-2015-1.0.110.0.exe</a>
        <br />
        (18.30 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This setup package will install all the necessary runtime components and
        dependencies for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x64 is
        included.  The .NET Framework 4.6 is required.
        <br />
        (sha1: 45de3da7a6cc8cf83947e1f8bc2cf7dc966fa48c)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-binary-bundle-Win32-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-binary-bundle-Win32-2005-1.0.110.0.zip">sqlite-netFx20-binary-bundle-Win32-2005-1.0.110.0.zip</a>
        <br />
        (1.98 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x86 and the .NET
        Framework 2.0 SP2 are required.
        <br />
        (sha1: 8d053573193a0c42a1018c109f07314ddffa9aed)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-binary-Win32-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-binary-Win32-2005-1.0.110.0.zip">sqlite-netFx20-binary-Win32-2005-1.0.110.0.zip</a>
        <br />
        (1.98 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005 SP1
        runtime for x86 and the .NET Framework 2.0 SP2 are required.
        <br />
        (sha1: eac6e68fb5ff0d9e14dd5140f63a557ec2d9ed6f)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-binary-bundle-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-binary-bundle-x64-2005-1.0.110.0.zip">sqlite-netFx20-binary-bundle-x64-2005-1.0.110.0.zip</a>
        <br />
        (2.28 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x64 and the .NET
        Framework 2.0 SP2 are required.
        <br />
        (sha1: 86a70e67b3fe679ee692ec60dd7fcf1f1505f8ae)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-binary-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-binary-x64-2005-1.0.110.0.zip">sqlite-netFx20-binary-x64-2005-1.0.110.0.zip</a>
        <br />
        (2.27 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005 SP1
        runtime for x64 and the .NET Framework 2.0 SP2 are required.
        <br />
        (sha1: 123b5aa4d088a54f131bcbbdb198b537090d4521)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-binary-bundle-Win32-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-binary-bundle-Win32-2008-1.0.110.0.zip">sqlite-netFx35-binary-bundle-Win32-2008-1.0.110.0.zip</a>
        <br />
        (2.43 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x86 and the .NET
        Framework 3.5 SP1 are required.
        <br />
        (sha1: 2796a78e27cdcb5c9bc5de311e35e6107836c05c)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-binary-Win32-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-binary-Win32-2008-1.0.110.0.zip">sqlite-netFx35-binary-Win32-2008-1.0.110.0.zip</a>
        <br />
        (2.42 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008 SP1
        runtime for x86 and the .NET Framework 3.5 SP1 are required.
        <br />
        (sha1: 0179eaa69ab67172e811ca50505619b15d4fe0e3)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-binary-bundle-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-binary-bundle-x64-2008-1.0.110.0.zip">sqlite-netFx35-binary-bundle-x64-2008-1.0.110.0.zip</a>
        <br />
        (2.55 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x64 and the .NET
        Framework 3.5 SP1 are required.
        <br />
        (sha1: 21cd2ec7516c089bb333bd507840fa9a45ec058b)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-binary-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-binary-x64-2008-1.0.110.0.zip">sqlite-netFx35-binary-x64-2008-1.0.110.0.zip</a>
        <br />
        (2.54 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008 SP1
        runtime for x64 and the .NET Framework 3.5 SP1 are required.
        <br />
        (sha1: b5acaa975901d4a19d5517ab24bf85b5dfc79c7b)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-binary-bundle-Win32-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-binary-bundle-Win32-2010-1.0.110.0.zip">sqlite-netFx40-binary-bundle-Win32-2010-1.0.110.0.zip</a>
        <br />
        (2.68 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x86 and the .NET
        Framework 4.0 are required.
        <br />
        (sha1: 160f07bf6d2b3b0f93f37f228c5d8ecc697867e8)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-binary-Win32-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-binary-Win32-2010-1.0.110.0.zip">sqlite-netFx40-binary-Win32-2010-1.0.110.0.zip</a>
        <br />
        (2.67 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010 SP1
        runtime for x86 and the .NET Framework 4.0 are required.
        <br />
        (sha1: 62df56da0010cddd497a1ca0306b3c5f121314a0)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-binary-bundle-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-binary-bundle-x64-2010-1.0.110.0.zip">sqlite-netFx40-binary-bundle-x64-2010-1.0.110.0.zip</a>
        <br />
        (2.73 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x64 and the .NET
        Framework 4.0 are required.
        <br />
        (sha1: ea5f682a3d384e6cb0ea524f712b19b3e1767599)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-binary-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-binary-x64-2010-1.0.110.0.zip">sqlite-netFx40-binary-x64-2010-1.0.110.0.zip</a>
        <br />
        (2.72 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010 SP1
        runtime for x64 and the .NET Framework 4.0 are required.
        <br />
        (sha1: 5223c652ab2d3790571e06d6ee5d2b638ac03574)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-binary-bundle-Win32-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-binary-bundle-Win32-2012-1.0.110.0.zip">sqlite-netFx45-binary-bundle-Win32-2012-1.0.110.0.zip</a>
        <br />
        (2.57 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x86 and
        the .NET Framework 4.5 are required.
        <br />
        (sha1: fbf3439df61baade6660f3d03401088415e7b0f0)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-binary-Win32-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-binary-Win32-2012-1.0.110.0.zip">sqlite-netFx45-binary-Win32-2012-1.0.110.0.zip</a>
        <br />
        (2.63 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x86 and the .NET Framework 4.5 are required.
        <br />
        (sha1: aae1987642bc8bc8eefdadc38edfa2722efd83e2)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-binary-bundle-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-binary-bundle-x64-2012-1.0.110.0.zip">sqlite-netFx45-binary-bundle-x64-2012-1.0.110.0.zip</a>
        <br />
        (2.63 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x64 and
        the .NET Framework 4.5 are required.
        <br />
        (sha1: 253bbc9a2413b1bc8da7ef6ab49d54034b8cab15)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-binary-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-binary-x64-2012-1.0.110.0.zip">sqlite-netFx45-binary-x64-2012-1.0.110.0.zip</a>
        <br />
        (2.72 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x64 and the .NET Framework 4.5 are required.
        <br />
        (sha1: 02b50f89b6a51db5006cd27b8d14c42d3c4a1dd6)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-binary-bundle-Win32-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-binary-bundle-Win32-2013-1.0.110.0.zip">sqlite-netFx451-binary-bundle-Win32-2013-1.0.110.0.zip</a>
        <br />
        (2.58 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x86 and the
        .NET Framework 4.5.1 are required.
        <br />
        (sha1: 63ac7c5df51552e5778e76b0a6279e9a5ba77995)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-binary-Win32-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-binary-Win32-2013-1.0.110.0.zip">sqlite-netFx451-binary-Win32-2013-1.0.110.0.zip</a>
        <br />
        (2.63 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x86 and the .NET Framework 4.5.1 are required.
        <br />
        (sha1: ef8d7cac62528cb2feeec9227dfa07fe55530751)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-binary-bundle-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-binary-bundle-x64-2013-1.0.110.0.zip">sqlite-netFx451-binary-bundle-x64-2013-1.0.110.0.zip</a>
        <br />
        (2.63 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x64 and the
        .NET Framework 4.5.1 are required.
        <br />
        (sha1: 248692d48450f51034cdf82238d28ac0d25e12d5)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-binary-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-binary-x64-2013-1.0.110.0.zip">sqlite-netFx451-binary-x64-2013-1.0.110.0.zip</a>
        <br />
        (2.73 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x64 and the .NET Framework 4.5.1 are required.
        <br />
        (sha1: 1a4cc8e84029898b2dcfc239e13afced5f3370fe)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 32-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-binary-bundle-Win32-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-binary-bundle-Win32-2015-1.0.110.0.zip">sqlite-netFx46-binary-bundle-Win32-2015-1.0.110.0.zip</a>
        <br />
        (3.21 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x86 and the
        .NET Framework 4.6 are required.
        <br />
        (sha1: 7dd5bdaf7defc1bd41ebcffd57e3560c584b4607)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-binary-Win32-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-binary-Win32-2015-1.0.110.0.zip">sqlite-netFx46-binary-Win32-2015-1.0.110.0.zip</a>
        <br />
        (3.42 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x86 and the .NET Framework 4.6 are required.
        <br />
        (sha1: baf78425fd9baeab45654da2561726baf27567c8)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for 64-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-binary-bundle-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-binary-bundle-x64-2015-1.0.110.0.zip">sqlite-netFx46-binary-bundle-x64-2015-1.0.110.0.zip</a>
        <br />
        (3.27 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x64 and the
        .NET Framework 4.6 are required.
        <br />
        (sha1: 72fb40d0d7e80fc6ef3c170d90275e8db075fec4)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-binary-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-binary-x64-2015-1.0.110.0.zip">sqlite-netFx46-binary-x64-2015-1.0.110.0.zip</a>
        <br />
        (3.57 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x64 and the .NET Framework 4.6 are required.
        <br />
        (sha1: 859295c6fba9cea20c57a8f0f3d269fe1ff07d0d)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for Mono on POSIX (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-binary-Mono-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-binary-Mono-2013-1.0.110.0.zip">sqlite-netFx451-binary-Mono-2013-1.0.110.0.zip</a>
        <br />
        (1.29 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the managed binaries for the Mono
        version of the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The
        <a href="https://www.mono-project.com/">Mono runtime</a> (4.2.3.4 or
        higher) is required.
        <br />
        (sha1: 183d1fcb3bca7024c1c516ae0aa7d8ed05c805ce)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for the .NET Standard 2.0 (.NET Core 2.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netStandard20-binary"></a>
        <a href="/downloads/1.0.110.0/sqlite-netStandard20-binary-1.0.110.0.zip">sqlite-netStandard20-binary-1.0.110.29.zip</a>
        <br />
        (0.29 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the managed binaries for the .NET
        Standard 2.0 version of the System.Data.SQLite 1.0.110.0 (3.27.2)
        package.  The <a href="https://dotnet.github.io/">.NET Core</a>
        runtime (2.0 or higher) is required.
        <br />
        (sha1: 8b103bc05d8c4c07bc6f7fa48cd29c4d52760ad8)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-static-binary-bundle-Win32-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-static-binary-bundle-Win32-2005-1.0.110.0.zip">sqlite-netFx20-static-binary-bundle-Win32-2005-1.0.110.0.zip</a>
        <br />
        (2.18 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x86 is statically
        linked.  The .NET Framework 2.0 SP2 is required.
        <br />
        (sha1: 270b692efbc48c580d3bd74d57f2703dd5e41da0)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-static-binary-Win32-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-static-binary-Win32-2005-1.0.110.0.zip">sqlite-netFx20-static-binary-Win32-2005-1.0.110.0.zip</a>
        <br />
        (2.17 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005 SP1
        runtime for x86 is statically linked.  The .NET Framework 2.0 SP2 is
        required.
        <br />
        (sha1: 0996caabaccf3f42fe723002b73ac13f24ff72ab)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 2.0 SP2)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-static-binary-bundle-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-static-binary-bundle-x64-2005-1.0.110.0.zip">sqlite-netFx20-static-binary-bundle-x64-2005-1.0.110.0.zip</a>
        <br />
        (2.42 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2005 SP1 runtime for x64 is statically
        linked.  The .NET Framework 2.0 SP2 is required.
        <br />
        (sha1: c18e09240c835090199fac2f3200a17bd82a5135)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx20-static-binary-x64-2005"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx20-static-binary-x64-2005-1.0.110.0.zip">sqlite-netFx20-static-binary-x64-2005-1.0.110.0.zip</a>
        <br />
        (2.41 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2005 SP1
        runtime for x64 is statically linked.  The .NET Framework 2.0 SP2 is
        required.
        <br />
        (sha1: a46d3003a16614b4cdfbeeb2fddced1f8fffd678)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-static-binary-bundle-Win32-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-static-binary-bundle-Win32-2008-1.0.110.0.zip">sqlite-netFx35-static-binary-bundle-Win32-2008-1.0.110.0.zip</a>
        <br />
        (2.62 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x86 is statically
        linked.  The .NET Framework 3.5 SP1 is required.
        <br />
        (sha1: a2eedfad7f8f12968cea30929c1e25cd56448956)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-static-binary-Win32-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-static-binary-Win32-2008-1.0.110.0.zip">sqlite-netFx35-static-binary-Win32-2008-1.0.110.0.zip</a>
        <br />
        (2.62 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008 SP1
        runtime for x86 is statically linked.  The .NET Framework 3.5 SP1 is
        required.
        <br />
        (sha1: 95cc99cf6d5e24e1a7fcabb66bfdaeb7581dcb7c)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 3.5 SP1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-static-binary-bundle-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-static-binary-bundle-x64-2008-1.0.110.0.zip">sqlite-netFx35-static-binary-bundle-x64-2008-1.0.110.0.zip</a>
        <br />
        (2.71 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2008 SP1 runtime for x64 is statically
        linked.  The .NET Framework 3.5 SP1 is required.
        <br />
        (sha1: 4f22e93c7033ab992ef8fb30d10d1558bec4b9d7)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-static-binary-x64-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-static-binary-x64-2008-1.0.110.0.zip">sqlite-netFx35-static-binary-x64-2008-1.0.110.0.zip</a>
        <br />
        (2.70 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2008 SP1
        runtime for x64 is statically linked.  The .NET Framework 3.5 SP1 is
        required.
        <br />
        (sha1: ab9c1b974e60635185c76a4ee237059555e2d463)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-static-binary-bundle-Win32-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-static-binary-bundle-Win32-2010-1.0.110.0.zip">sqlite-netFx40-static-binary-bundle-Win32-2010-1.0.110.0.zip</a>
        <br />
        (2.87 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x86 is statically
        linked.  The .NET Framework 4.0 is required.
        <br />
        (sha1: 2afa7c7540916805ac950d9de382d89f5d42a35a)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-static-binary-Win32-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-static-binary-Win32-2010-1.0.110.0.zip">sqlite-netFx40-static-binary-Win32-2010-1.0.110.0.zip</a>
        <br />
        (2.86 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010 SP1
        runtime for x86 is statically linked.  The .NET Framework 4.0 is
        required.
        <br />
        (sha1: 976420d83591f164d3f90102b8c363ee3f4d163e)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 4.0)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-static-binary-bundle-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-static-binary-bundle-x64-2010-1.0.110.0.zip">sqlite-netFx40-static-binary-bundle-x64-2010-1.0.110.0.zip</a>
        <br />
        (2.90 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2010 SP1 runtime for x64 is statically
        linked.  The .NET Framework 4.0 is required.
        <br />
        (sha1: c78f16668797a594ffb2090689c9e27ca3863c6b)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx40-static-binary-x64-2010"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx40-static-binary-x64-2010-1.0.110.0.zip">sqlite-netFx40-static-binary-x64-2010-1.0.110.0.zip</a>
        <br />
        (2.90 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2010 SP1
        runtime for x64 is statically linked.  The .NET Framework 4.0 is
        required.
        <br />
        (sha1: 420b73f6a4f18899401cb15a81abfdd19a2045b7)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-static-binary-bundle-Win32-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-static-binary-bundle-Win32-2012-1.0.110.0.zip">sqlite-netFx45-static-binary-bundle-Win32-2012-1.0.110.0.zip</a>
        <br />
        (2.89 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x86 is
        statically linked.  The .NET Framework 4.5 is required.
        <br />
        (sha1: 39ba46f4165785db65fc99bc65b38387a0dd1f22)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-static-binary-Win32-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-static-binary-Win32-2012-1.0.110.0.zip">sqlite-netFx45-static-binary-Win32-2012-1.0.110.0.zip</a>
        <br />
        (2.95 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x86 is statically linked.  The .NET Framework 4.5
        is required.
        <br />
        (sha1: d2c4d9bbb98ba83ba81722996293a092267e41ef)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 4.5)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-static-binary-bundle-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-static-binary-bundle-x64-2012-1.0.110.0.zip">sqlite-netFx45-static-binary-bundle-x64-2012-1.0.110.0.zip</a>
        <br />
        (2.88 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2012 Update 4 runtime for x64 is
        statically linked.  The .NET Framework 4.5 is required.
        <br />
        (sha1: bde011a0f0d0c09361429c4c23c0ba0cd101dc9c)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx45-static-binary-x64-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx45-static-binary-x64-2012-1.0.110.0.zip">sqlite-netFx45-static-binary-x64-2012-1.0.110.0.zip</a>
        <br />
        (2.98 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2012
        Update 4 runtime for x64 is statically linked.  The .NET Framework 4.5
        is required.
        <br />
        (sha1: e0e4dfdd83719baae564ee6762c461eb7950871f)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-static-binary-bundle-Win32-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-static-binary-bundle-Win32-2013-1.0.110.0.zip">sqlite-netFx451-static-binary-bundle-Win32-2013-1.0.110.0.zip</a>
        <br />
        (2.92 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x86 is
        statically linked.  The .NET Framework 4.5.1 is required.
        <br />
        (sha1: c3ee1e5a87343a511f7196fe2a0cc06d9a32c9b8)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-static-binary-Win32-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-static-binary-Win32-2013-1.0.110.0.zip">sqlite-netFx451-static-binary-Win32-2013-1.0.110.0.zip</a>
        <br />
        (2.97 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x86 is statically linked.  The .NET Framework 4.5.1
        is required.
        <br />
        (sha1: 7fd2c835165cb2746ff5fb23c422a9491d177182)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 4.5.1)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-static-binary-bundle-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-static-binary-bundle-x64-2013-1.0.110.0.zip">sqlite-netFx451-static-binary-bundle-x64-2013-1.0.110.0.zip</a>
        <br />
        (2.92 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2013 Update 2 runtime for x64 is
        statically linked.  The .NET Framework 4.5.1 is required.
        <br />
        (sha1: 39d790649154d16d6424f32dae917f55cb9c968c)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx451-static-binary-x64-2013"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx451-static-binary-x64-2013-1.0.110.0.zip">sqlite-netFx451-static-binary-x64-2013-1.0.110.0.zip</a>
        <br />
        (3.02 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2013
        Update 2 runtime for x64 is statically linked.  The .NET Framework 4.5.1
        is required.
        <br />
        (sha1: fea21c9a78a7d4079eaa9b910f67c1181bc81e40)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 32-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-static-binary-bundle-Win32-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-static-binary-bundle-Win32-2015-1.0.110.0.zip">sqlite-netFx46-static-binary-bundle-Win32-2015-1.0.110.0.zip</a>
        <br />
        (3.72 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x86 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x86 is
        statically linked.  The .NET Framework 4.6 is required.
        <br />
        (sha1: 6768c66eefea3565cfff094d7d90518ddb2eadaf)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-static-binary-Win32-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-static-binary-Win32-2015-1.0.110.0.zip">sqlite-netFx46-static-binary-Win32-2015-1.0.110.0.zip</a>
        <br />
        (3.94 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x86 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x86 is statically linked.  The .NET Framework 4.6
        is required.
        <br />
        (sha1: 859d2756c7ca885ed9f64a29395c24f4a4aa8772)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Statically-Linked Binaries for 64-bit Windows (.NET Framework 4.6)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-static-binary-bundle-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-static-binary-bundle-x64-2015-1.0.110.0.zip">sqlite-netFx46-static-binary-bundle-x64-2015-1.0.110.0.zip</a>
        <br />
        (3.75 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package features the mixed-mode assembly and contains all
        the binaries for the x64 version of the System.Data.SQLite 1.0.110.0
        (3.27.2) package.  The Visual C++ 2015 Update 3 runtime for x64 is
        statically linked.  The .NET Framework 4.6 is required.
        <br />
        (sha1: c40fc597d11d51295b4ec831f6b9ee6db6cee43a)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx46-static-binary-x64-2015"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx46-static-binary-x64-2015-1.0.110.0.zip">sqlite-netFx46-static-binary-x64-2015-1.0.110.0.zip</a>
        <br />
        (4.06 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the x64 version of the
        System.Data.SQLite 1.0.110.0 (3.27.2) package.  The Visual C++ 2015
        Update 3 runtime for x64 is statically linked.  The .NET Framework 4.6
        is required.
        <br />
        (sha1: 7399f35ffafb525d3bbecc944354f57ded228a17)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Precompiled Binaries for Windows CE (.NET Compact Framework)</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx35-binary-PocketPC-ARM-2008"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx35-binary-PocketPC-ARM-2008-1.0.110.0.zip">sqlite-netFx35-binary-PocketPC-ARM-2008-1.0.110.0.zip</a>
        <br />
        (1.53 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the PocketPC version
        of the System.Data.SQLite 1.0.110.0 (3.27.2) package.  The included native
        binaries should work on all supported ARM versions of Windows CE prior
        to Windows Embedded Compact 2013.  The .NET Compact Framework 3.5 is
        required.
        <br />
        (sha1: c05143466e8456243ca97f9eb7665770e98d3abd)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx39-binary-WinCE-ARM-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx39-binary-WinCE-ARM-2012-1.0.110.0.zip">sqlite-netFx39-binary-WinCE-ARM-2012-1.0.110.0.zip</a>
        <br />
        (1.69 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the Windows Embedded
        Compact 2013 (ARM) version of the System.Data.SQLite 1.0.110.0 (3.27.2)
        package.  The .NET Compact Framework 3.9 is required.
        <br />
        (sha1: 3ff3a4f8cc725881572ae96852899a412d907dbd)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a name="sqlite-netFx39-binary-WinCE-x86-2012"></a>
        <a href="/downloads/1.0.110.0/sqlite-netFx39-binary-WinCE-x86-2012-1.0.110.0.zip">sqlite-netFx39-binary-WinCE-x86-2012-1.0.110.0.zip</a>
        <br />
        (1.74 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This binary package contains all the binaries for the Windows Embedded
        Compact 2013 (x86) version of the System.Data.SQLite 1.0.110.0 (3.27.2)
        package.  The .NET Compact Framework 3.9 is required.
        <br />
        (sha1: 23c48f914dcff7ca34de3892cad4fde29c717b60)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <a name="nuGetPackages"></a>
        <b>Official NuGet Packages</b>
      </td>
    </tr>

    <tr bgcolor="#fff1c8">
      <td colspan="4" class="importantNotes">
        Generally, the official NuGet packages should be obtained from the
        <a href="https://www.nuget.org/profiles/SQLite">NuGet Gallery</a>;
        however, they are also included here as &quot;local downloads&quot; for
        reference.  They should be absolutely identical to those listed on the
        NuGet Gallery with the same name and version.  The SHA1 hashes listed
        below may be used for comparison purposes.
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.1.0.110.0.nupkg">System.Data.SQLite.1.0.110.0.nupkg</a>
        <br />
        (0.00 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package includes all the binaries for both the x86 and x64
        versions of System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework
        3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2
        -OR- .NET Core 2.0 is required.  For the included Windows native
        binaries, the version of the Visual C++ runtime corresponding to the
        .NET Framework used by the associated managed assembly is statically
        linked.  For the included Linux native binaries, Ubuntu 16.04 LTS
        compatible runtime libraries are required.  For the included macOS
        native binaries, macOS Sierra compatible runtime libraries are required.
        <br />
        <big><b>This package depends on the &quot;EntityFramework&quot;
        package, version 6.0 or higher (indirectly via the
        &quot;System.Data.SQLite.EF6&quot; package).</b></big>
        <br />
        <br />
        <big><b><i>As of version 1.0.92.0, this package will not directly
        contain any of the required binaries.  Instead, this package will
        depend on the &quot;System.Data.SQLite.Core&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: 25cc6ba350916be15c88ef4ed36b605d368024b9)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.1.0.110.0.nupkg">System.Data.SQLite.Core.1.0.110.0.nupkg</a>
        <br />
        (11.91 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains all the binaries for both the x86 and x64
        versions of System.Data.SQLite 1.0.110.0 (3.27.2), <big><b>except those
        needed to support LINQ and Entity Framework 6</b></big>.  The .NET
        Framework 3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7,
        4.7.1, or 4.7.2 is required -OR- .NET Core 2.0 is required.  For the
        included Windows native binaries, the version of the Visual C++ runtime
        corresponding to the .NET Framework used by the associated managed
        assembly is statically linked.  For the included Linux native binaries,
        Ubuntu 16.04 LTS compatible runtime libraries are required.  For the
        included macOS native binaries, macOS Sierra compatible runtime
        libraries are required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: 51aeb7a4b4578057936f97996c3093699111be7b)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg">System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg</a>
        <br />
        (1.45 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains the managed binaries for System.Data.SQLite
        1.0.110.0.  The .NET Framework 3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6,
        4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2 is required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        <br />
        <big><b><i>This NuGet package does not include any code from the native
        SQLite core library and will not work properly without the native
        assembly &quot;SQLite.Interop.dll&quot; compiled for the processor
        architecture of the host process being present in a directory in the
        native library search path.</i></b></big>
        <br />
        <br />
        (sha1: d4ce92c36f29bfac7ef72dacf85ae9ec74566b13)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.EF6.1.0.110.0.nupkg">System.Data.SQLite.EF6.1.0.110.0.nupkg</a>
        <br />
        (0.18 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains just the binaries to support Entity
        Framework 6 using System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET
        Framework 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, or
        4.7.2 is required.
        <br />
        <big><b>This package depends on the &quot;EntityFramework&quot;
        package, version 6.0 or higher.</b></big>
        <br />
        (sha1: d76159f815329abd57eacd7f6997c2a1648649e4)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Linq.1.0.110.0.nupkg">System.Data.SQLite.Linq.1.0.110.0.nupkg</a>
        <br />
        (0.22 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains just the binaries to support LINQ using
        System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework 3.5 SP1, 4.0,
        4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2 is required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: 65444e112e98a2f26f83087644082c54e23eb581)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.MSIL.1.0.110.0.nupkg">System.Data.SQLite.MSIL.1.0.110.0.nupkg</a>
        <br />
        (0.00 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains the managed binaries for System.Data.SQLite
        1.0.110.0.  The .NET Framework 3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6,
        4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2 is required.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        <br />
        <big><b><i>This NuGet package does not include any code from the native
        SQLite core library and will not work properly without the native
        assembly &quot;SQLite.Interop.dll&quot; compiled for the processor
        architecture of the host process being present in a directory in the
        native library search path.</i></b></big>
        <br />
        <br />
        <big><b><i>As of version 1.0.95.0, this package will not directly
        contain any of the required binaries. Instead, this package will
        depend on the &quot;System.Data.SQLite.Core.MSIL&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: ad803972c1252a3a419b46fc75471b2ef45b67f1)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x86.1.0.110.0.nupkg">System.Data.SQLite.x86.1.0.110.0.nupkg</a>
        <br />
        (4.32 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains all the binaries for the x86 version of
        System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework 3.5 SP1,
        4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2 is
        required.  For the included native binaries, the version of the Visual
        C++ runtime corresponding to the .NET Framework used by the associated
        managed assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: 478ce10e64488630db356170639ebeb02ddf2509)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x64.1.0.110.0.nupkg">System.Data.SQLite.x64.1.0.110.0.nupkg</a>
        <br />
        (4.90 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains all the binaries for the x64 version of
        System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework 3.5 SP1,
        4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, or 4.7.2 is
        required.  For the included native binaries, the version of the Visual
        C++ runtime corresponding to the .NET Framework used by the associated
        managed assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: ffda24ef14ebf8834d785158195a3ce0e193a68a)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <a name="legacyVersions"></a>
        <b>Legacy Versions</b>
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="https://sourceforge.net/projects/sqlite-dotnet2/files/SQLite%20for%20ADO.NET%202.0/1.0.66.0/SQLite-1.0.66.0-setup.exe/download">SQLite-1.0.66.0-setup.exe</a>
      </td>
      <td width="5"></td>
      <td valign="top">
        Legacy versions may still be found at <a href="https://sourceforge.net/projects/sqlite-dotnet2/">SourceForge</a>, though there have been no
        updates there since April of 2010.
      </td>
    </tr>
  </table>

  <h3 class="pageSubSubHeader">Build Product Names</h3>

  <p>
    Beginning with System.Data.SQLite version 1.0.101.0 (3.12.2), the following
    templates will be used for the names of the build products:

    <ol>
      <li><b>sqlite-netFx-source-</b>version<b>.zip</b></li>
      <li><b>sqlite-netFx-source-</b>version<b>.tar.gz</b></li>
      <li><b>sqlite-netFx-full-source-</b>version<b>.zip</b></li>
      <li><b>sqlite-netFx-full-source-</b>version<b>.tar.gz</b></li>
      <li><b>sqlite-</b>framework<b>-setup-</b>cpu<b>-</b>year<b>-</b>version<b>.exe</b></li>
      <li><b>sqlite-</b>framework<b>-setup-bundle-</b>cpu<b>-</b>year<b>-</b>version<b>.exe</b></li>
      <li><b>sqlite-</b>framework<b>-binary-</b>platform<b>-</b>year<b>-</b>version<b>.zip</b></li>
      <li><b>sqlite-</b>framework<b>-binary-bundle-</b>platform<b>-</b>year<b>-</b>version<b>.zip</b></li>
      <li><b>sqlite-</b>framework<b>-static-binary-</b>platform<b>-</b>year<b>-</b>version<b>.zip</b></li>
      <li><b>sqlite-</b>framework<b>-static-binary-bundle-</b>platform<b>-</b>year<b>-</b>version<b>.zip</b></li>
      <li><b>sqlite-netFx-source-</b>date<b>.zip</b></li>
      <li><b>sqlite-netFx-full-source-</b>date<b>.zip</b></li>
      <li><b>System.Data.SQLite.</b>version<b>.nupkg</b></li>
      <li><b>System.Data.SQLite.</b>variant<b>.</b>version<b>.nupkg</b></li>
      <li><b>System.Data.SQLite.</b>variant<b>.</b>releaseType<b>.</b>version<b>.nupkg</b></li>
    </ol>
  </p>

  <p>
    Templates (1), (2), (3), and (4) are used for source-code packages.
    Templates (1) and (3) are used for generic source-code packages and
    templates (2) and (4) are used for source-code packages that are generally
    only useful on unix-like platforms.  Templates (3) and (4) are used for
    source-code packages that include the extra files needed to run the unit
    test suite.
  </p>

  <p>
    Templates (5) and (6) are used for the setup packages.  Template (6) is
    used for the setup package containing the mixed-mode assembly.
  </p>

  <p>
    Templates (7) and (8) are used for the precompiled binary packages.
    Template (8) is used for the precompiled binary package containing the
    mixed-mode assembly.  Templates (9) and (10) are used for the precompiled
    binary packages statically linked to the Visual C++ runtime.  Template (10)
    is used for the precompiled binary package containing the mixed-mode
    assembly statically linked to the Visual C++ runtime.
  </p>

  <p>
    Templates (11) and (12) are used for unofficial pre-release
    &quot;snapshots&quot; of source code.
  </p>

  <p>
    Templates (13), (14), and (15) are used for the official NuGet packages.
  </p>

  <p>
    The <b>framework</b> in templates (5), (6), (7), (8), (9), and (10) will
    be one of netFx20, netFx35, netFx40, netFx45, netFx451, netFx452, netFx46,
    netFx461, netFx462, netFx47, netFx471, netFx472.
  </p>

  <p>
    The <b>cpu</b> in templates (5) and (6) will be one of x86, x64, arm, ia64.
  </p>

  <p>
    The <b>platform</b> in templates (7), (8), (9), and (10) will be one of
    Win32, x64, PocketPC, PocketPC-ARM, PocketPC-x86, WinCE-ARM, WinCE-x86,
    Mono.
  </p>

  <p>
    The <b>year</b> in templates (5), (6), (7), (8), (9), and (10) will be
    one of 2005, 2008, 2010, 2012, 2013, 2015, 2017, 20XX, NetStandard20.
  </p>

  <p>
    The <b>version</b> in templates (1), (2), (3), (4), (5), (6), (7), (8),
    (9), (10), (13), (14), and (15) is the dot-delimited version number of
    the primary System.Data.SQLite assembly.
  </p>

  <p>
    The <b>date</b> in template (11) and (12) is of the form: YYYYMMDDHHMM
  </p>

  <p>
    The <b>variant</b> in template (14) and (15) will be MSIL, x86, or x64.
    Alternatively, it may be absent, which represents the default variant.
  </p>

  <p>
    The <b>releaseType</b> in template (15) will be Beta or Test.
    Alternatively, it may be absent, which represents the default release type.
    <ul>
    <li>The &quot;Beta&quot; release type is used to indicate that the package
    was intended to be used for
    <a href="https://en.wikipedia.org/wiki/Software_release_life_cycle#Beta">beta</a>
    testing.</li>
    <li>The &quot;Test&quot; release type is used to indicate that the package
    was intended to be used for
    <a href="https://en.wikipedia.org/wiki/Software_release_life_cycle#Release_candidate">release candidate</a>
    testing.</li>
    </ul>
  </p>

  <h3 class="pageSubSubHeader">Canonical Source Code</h3>

  <p>
    The canonical System.Data.SQLite source code is maintained in a Fossil
    repository that is available for anonymous read-only access. Anyone can view
    the repository contents and download historical versions of individual files
    or ZIP archives of historical check-ins.
  </p>

  <p>
    The complete source tree for any
    <a href="/index.html/timeline?n=20&y=ci">check-in</a>
    may always be downloaded using the &quot;Tarball&quot; or &quot;ZIP
    archive&quot; links available from each check-in detail page.
  </p>
</nowiki>