System.Data.SQLite
View Ticket
Not logged in
Ticket UUID: a91cb269f98a9809daf55a460151ea07514206ee
Title: Cannot upgrade version via NuGet
Status: Closed Type: Packaging
Severity: Important Priority: Medium
Subsystem: NuGetPackage Resolution: Need_More_Info
Last Modified: 2018-02-27 00:48:35
Version Found In: 1.0.106 --> 1.0.107
User Comments:
anonymous added on 2018-02-12 15:41:31:
All my unit test projects use a "master" app.config and I link it into all the projects.  This makes managing settings much easier rather than having to maintain them in each project.

The NuGet packages do not like this and report this error when trying to upgrade SQLite versions:

System.Runtime.InteropServices.COMException (0x80004005): Cannot add the file 'app.config'. There is already a linked file in this folder with the same name.

mistachkin added on 2018-02-13 00:55:20:
Have you been able to upgrade via NuGet before, e.g. from 1.0.105 to 1.0.106?

Are you using the LINQ/EF6 support?

mistachkin added on 2018-02-13 01:02:02:
Is there any additional information provided, e.g. a stack trace?

The NuGet packages do not contain an 'app.config' file; however, they do
contain files that transform existing 'app.config' / 'web.config' files
to add configuration for LINQ / EF6.  It sounds like the exception is being
raised during the transform process.

mistachkin added on 2018-02-13 21:03:41:
This may be a bug in NuGet itself, see:

    [https://github.com/NuGet/Home/issues/1006]

    [https://github.com/NuGet/Home/issues/1111]

I'm not sure which version(s) of NuGet may be impacted; however, since this
issue has never been reported before, I suspect it may only impact recent
versions of NuGet.

mistachkin added on 2018-02-13 21:07:57:
Also see:

[https://github.com/NuGet/Home/issues/1119]