System.Data.SQLite
Check-in [e517bb27e5]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:More updates to the downloads page for the 1.0.110.0 release (NuGet packages were rebuilt).
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | preRelease
Files: files | file ages | folders
SHA1:e517bb27e53b81962a85f778942b4b8353c892f5
User & Date: mistachkin 2019-03-03 22:19:02
Context
2019-03-03
22:26
Final updates for release 1.0.110.0. check-in: c9efdeced8 user: mistachkin tags: trunk, release, release-1.0.110.0
22:19
More updates to the downloads page for the 1.0.110.0 release (NuGet packages were rebuilt). Closed-Leaf check-in: e517bb27e5 user: mistachkin tags: preRelease
21:47
Updates to the downloads page for the 1.0.110.0 release. check-in: 4c5afd3f14 user: mistachkin tags: preRelease
Changes
Hide Diffs Unified Diffs Ignore Whitespace Patch

Changes to www/downloads.wiki.

2279
2280
2281
2282
2283
2284
2285
2286
2287
2288
2289
2290
2291
2292
2293
2294
2295
2296
2297
2298
2299
2300
2301
2302
....
2306
2307
2308
2309
2310
2311
2312
2313
2314
2315
2316
2317
2318
2319
2320
....
2333
2334
2335
2336
2337
2338
2339
2340
2341
2342
2343
2344
2345
2346
2347
....
2354
2355
2356
2357
2358
2359
2360
2361
2362
2363
2364
2365
2366
2367
2368
....
2373
2374
2375
2376
2377
2378
2379
2380
2381
2382
2383
2384
2385
2386
2387
....
2409
2410
2411
2412
2413
2414
2415
2416
2417
2418
2419
2420
2421
2422
2423
....
2433
2434
2435
2436
2437
2438
2439
2440
2441
2442
2443
2444
2445
2446
2447
....
2457
2458
2459
2460
2461
2462
2463
2464
2465
2466
2467
2468
2469
2470
2471
        <big><b><i>As of version 1.0.92.0, this package will not directly
        contain any of the required binaries.  Instead, this package will
        depend on the &quot;System.Data.SQLite.Core&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: ff202a6a3f352fa0a818413d732d23a2032bcd46)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.1.0.110.0.nupkg">System.Data.SQLite.Core.1.0.110.0.nupkg</a>
        <br />
        (12.51 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains all the binaries for both the x86 and x64
        versions of System.Data.SQLite 1.0.110.0 (3.27.2), <big><b>except those
        needed to support LINQ and Entity Framework 6</b></big>.  The .NET
        Framework 3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or
................................................................................
        assembly is statically linked.  For the included Linux native binaries,
        Ubuntu 16.04 LTS compatible runtime libraries are required.  For the
        included macOS native binaries, macOS Sierra compatible runtime
        libraries are required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: a9ccdb58ddbc0e00b6b7430007597ffde6bd3235)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg">System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg</a>
................................................................................
        <big><b><i>This NuGet package does not include any code from the native
        SQLite core library and will not work properly without the native
        assembly &quot;SQLite.Interop.dll&quot; compiled for the processor
        architecture of the host process being present in a directory in the
        native library search path.</i></b></big>
        <br />
        <br />
        (sha1: afe793ee253ef68b16529f6853f5ac3ff6d12904)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.EF6.1.0.110.0.nupkg">System.Data.SQLite.EF6.1.0.110.0.nupkg</a>
................................................................................
        Framework 6 using System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET
        Framework 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or 4.7.1 is
        required.
        <br />
        <big><b>This package depends on the &quot;EntityFramework&quot;
        package, version 6.0 or higher.</b></big>
        <br />
        (sha1: 6f44ddda2990e67c85e667b7f6738be47197717c)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Linq.1.0.110.0.nupkg">System.Data.SQLite.Linq.1.0.110.0.nupkg</a>
................................................................................
      <td valign="top">
        This NuGet package contains just the binaries to support LINQ using
        System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework 3.5 SP1, 4.0,
        4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or 4.7.1 is required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: abec1f0014ddd41fd9fa4affffa96478a2c13297)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.MSIL.1.0.110.0.nupkg">System.Data.SQLite.MSIL.1.0.110.0.nupkg</a>
................................................................................
        <big><b><i>As of version 1.0.95.0, this package will not directly
        contain any of the required binaries. Instead, this package will
        depend on the &quot;System.Data.SQLite.Core.MSIL&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: c404b94edde3fa5dbc4b1097df742a643a2e551c)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x86.1.0.110.0.nupkg">System.Data.SQLite.x86.1.0.110.0.nupkg</a>
................................................................................
        corresponding to the .NET Framework used by the associated managed
        assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: 5bbdca1256a5a3b4faf4510baf7aefb878e3ac30)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x64.1.0.110.0.nupkg">System.Data.SQLite.x64.1.0.110.0.nupkg</a>
................................................................................
        corresponding to the .NET Framework used by the associated managed
        assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: 320f19980c0a0b0643397df4695575d3ffe3ab5e)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <a name="legacyVersions"></a>
        <b>Legacy Versions</b>







|








|







 







|







 







|







 







|







 







|







 







|







 







|







 







|







2279
2280
2281
2282
2283
2284
2285
2286
2287
2288
2289
2290
2291
2292
2293
2294
2295
2296
2297
2298
2299
2300
2301
2302
....
2306
2307
2308
2309
2310
2311
2312
2313
2314
2315
2316
2317
2318
2319
2320
....
2333
2334
2335
2336
2337
2338
2339
2340
2341
2342
2343
2344
2345
2346
2347
....
2354
2355
2356
2357
2358
2359
2360
2361
2362
2363
2364
2365
2366
2367
2368
....
2373
2374
2375
2376
2377
2378
2379
2380
2381
2382
2383
2384
2385
2386
2387
....
2409
2410
2411
2412
2413
2414
2415
2416
2417
2418
2419
2420
2421
2422
2423
....
2433
2434
2435
2436
2437
2438
2439
2440
2441
2442
2443
2444
2445
2446
2447
....
2457
2458
2459
2460
2461
2462
2463
2464
2465
2466
2467
2468
2469
2470
2471
        <big><b><i>As of version 1.0.92.0, this package will not directly
        contain any of the required binaries.  Instead, this package will
        depend on the &quot;System.Data.SQLite.Core&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: 25cc6ba350916be15c88ef4ed36b605d368024b9)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.1.0.110.0.nupkg">System.Data.SQLite.Core.1.0.110.0.nupkg</a>
        <br />
        (11.91 MiB)
      </td>
      <td width="5"></td>
      <td valign="top">
        This NuGet package contains all the binaries for both the x86 and x64
        versions of System.Data.SQLite 1.0.110.0 (3.27.2), <big><b>except those
        needed to support LINQ and Entity Framework 6</b></big>.  The .NET
        Framework 3.5 SP1, 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or
................................................................................
        assembly is statically linked.  For the included Linux native binaries,
        Ubuntu 16.04 LTS compatible runtime libraries are required.  For the
        included macOS native binaries, macOS Sierra compatible runtime
        libraries are required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: 51aeb7a4b4578057936f97996c3093699111be7b)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg">System.Data.SQLite.Core.MSIL.1.0.110.0.nupkg</a>
................................................................................
        <big><b><i>This NuGet package does not include any code from the native
        SQLite core library and will not work properly without the native
        assembly &quot;SQLite.Interop.dll&quot; compiled for the processor
        architecture of the host process being present in a directory in the
        native library search path.</i></b></big>
        <br />
        <br />
        (sha1: d4ce92c36f29bfac7ef72dacf85ae9ec74566b13)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.EF6.1.0.110.0.nupkg">System.Data.SQLite.EF6.1.0.110.0.nupkg</a>
................................................................................
        Framework 6 using System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET
        Framework 4.0, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or 4.7.1 is
        required.
        <br />
        <big><b>This package depends on the &quot;EntityFramework&quot;
        package, version 6.0 or higher.</b></big>
        <br />
        (sha1: d76159f815329abd57eacd7f6997c2a1648649e4)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.Linq.1.0.110.0.nupkg">System.Data.SQLite.Linq.1.0.110.0.nupkg</a>
................................................................................
      <td valign="top">
        This NuGet package contains just the binaries to support LINQ using
        System.Data.SQLite 1.0.110.0 (3.27.2).  The .NET Framework 3.5 SP1, 4.0,
        4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, or 4.7.1 is required.
        <br />
        <big><b>This package does not depend on any other package.</b></big>
        <br />
        (sha1: 65444e112e98a2f26f83087644082c54e23eb581)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.MSIL.1.0.110.0.nupkg">System.Data.SQLite.MSIL.1.0.110.0.nupkg</a>
................................................................................
        <big><b><i>As of version 1.0.95.0, this package will not directly
        contain any of the required binaries. Instead, this package will
        depend on the &quot;System.Data.SQLite.Core.MSIL&quot;,
        &quot;System.Data.SQLite.Linq&quot;, and
        &quot;System.Data.SQLite.EF6&quot; packages.</i></b></big>
        <br />
        <br />
        (sha1: ad803972c1252a3a419b46fc75471b2ef45b67f1)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x86.1.0.110.0.nupkg">System.Data.SQLite.x86.1.0.110.0.nupkg</a>
................................................................................
        corresponding to the .NET Framework used by the associated managed
        assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: 478ce10e64488630db356170639ebeb02ddf2509)
      </td>
    </tr>

    <tr>
      <td width="10">&nbsp;</td>
      <td width="30%" valign="top" align="right">
        <a href="/downloads/1.0.110.0/System.Data.SQLite.x64.1.0.110.0.nupkg">System.Data.SQLite.x64.1.0.110.0.nupkg</a>
................................................................................
        corresponding to the .NET Framework used by the associated managed
        assembly is statically linked.
        <br />
        <big><b>This is a legacy package; if possible, please use either the
        &quot;System.Data.SQLite&quot; or &quot;System.Data.SQLite.Core&quot;
        package instead.</b></big>
        <br />
        (sha1: ffda24ef14ebf8834d785158195a3ce0e193a68a)
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <a name="legacyVersions"></a>
        <b>Legacy Versions</b>